Sharpharp1
Apprentice

Simple Radio Button Rule not working post 4.6.11 upgrade

I have 2 Radio buttons on a FORM and have a rule for each button that go like this "If Button A changes" do this.

 

The rule for Button A, simply empties all the fields in Section B in a View (this works)

 

But the rule for Button B, which should also empty the fields in the same View, but for Section A fields does not work.

 

The idea is, the users can toggle between entering the details in Section A or B depending on which Radio button they click.

 

If i run the form, Radio Button B works ONCE, if i then click Radio Button A that works, but if click back on Button B, nothing happens.

 

I even put a message in the rule for Button B and that does not even come up in the above scenario.

 

Since the 4.6.11, we have had nothing but trouble with every single form and i'm sick to the back teeth of it.

K2 say there is an upgrade bug from 4.6.8 to 4.6.11 where the link between views and forms is broken, but they just want to fix it in the future, which leaves me to re-do all my form rules by having to re-add views and do the rules.

 

Well annoyed.

0 Kudos
Reply
2 Replies
scorpio
Novice

Re: Simple Radio Button Rule not working post 4.6.11 upgrade

Here is a sample view in 4.6.11, which works as you described:

 

1) the design:

 

3919iC01B23E608A810A8.png

 

More details would help come closer to the resolution.

 

Reply
Sharpharp1
Apprentice

Re: Simple Radio Button Rule not working post 4.6.11 upgrade

Thanks for your reply, really appreciate it.

 

Will give it a try.

 

 

0 Kudos
Reply