Not applicable

REST Service Instance SmartObjects only returning HTTP response Codes

If you are running into an issue where your REST based SmartObjects are only returning the HTTP response code and no data, or the data is blank, there is a simple fix. This issue is related to having a strange character or . (Period) character in the Service Instance System Name. This causes the K2 REST Broker to be confused and have a tough time returning values, only returning empty values and the HTTP Response code.


 


Resolution:


Simply recreate the REST Service Broker not using a strange character. Also recreate your smartobjects and you should see the SmartObjects returning all the correct data.


 

Reply
4 Replies
Kallie
Novice

Re: REST Service Instance SmartObjects only returning HTTP response Codes

Thank you for sharing this information.


For more information about REST please look at our online documentation here.


 


Kallie

0 Kudos
Reply
ConradMc
Contributor

Re: REST Service Instance SmartObjects only returning HTTP response Codes

I get issues in K2 Five with using REST.

 

I have followed the Open Weather Map example (which can be found as a video here: https://help.k2.com/onlinehelp/k2blackpearl/userguide/current/default.htm#ServiceBrokers/EndPoints/R...).

 

I have used exact same data as shown in tutorial and get no data back, I actually only appear to get 0 as the HttpStatusCode?

 

This website (https://help.k2.com/onlinehelp/k2cloud/userguide/update_3/default.htm#servicebrokers/endpoints/rest_...) states the following:

The REST Broker currently only supports portions of the Swagger v2 specification

 

The OpenWeather descriptor file is Swagger v2 - is this the reason why?

 

Can anyone confirm that this example still works in K2 Five?

 

 

Thanks

0 Kudos
Reply
ugofranklyn25
Novice

Re: REST Service Instance SmartObjects only returning HTTP response Codes

Hi,

 

I am experiencing same issue, the rest api only returns the Response code without the response body.

 

Could you share more tips on how i could get this resolved.

 

Regards,

Reply
renet123
Scholar

Re: REST Service Instance SmartObjects only returning HTTP response Codes

anyone find a good tutorial on this? im stuck too.
0 Kudos
Reply