JoseRomeu
Novice

Problems with SMTP server

Hello, I have configured a standalone server where the e-mail server is a hMailServer. When I try to test the SMTP connection, it fails with a 501 error, because the K2 server is sending the commando EHLO without a server name. Is there any place where I must configure this server name?

 

Best regards

0 Kudos
Reply
2 Replies
Sharpharp1
Apprentice

Re: Problems with SMTP server

SMTP can be quite tricky, it took me a while to get SMTP and Exchange SMart Actions to work on the same server.

 

For starters. the SMTP magic all happens in the connectionstringeditor, have you set that up correctly?

0 Kudos
Reply
JoseRomeu
Novice

Re: Problems with SMTP server

Hello,  yes, I think I have the connection string well configured. In fact, I can connect with the SMTP server. The problem is that K2 isn't following the protocol, because it is sending the EHLO command without the domain name:

 

"DEBUG"    1932    "2016-12-01 12:13:44.375"    "Creating session 55"
"TCPIP"    1932    "2016-12-01 12:13:44.375"    "TCP - 151.184.13.169 connected to 151.184.13.169:587."
"DEBUG"    1932    "2016-12-01 12:13:44.375"    "TCP connection started for session 48"
"SMTPD"    1932    48    "2016-12-01 12:13:44.375"    "151.184.13.169"    "SENT: 220 BIOSBPM01 ESMTP"
"DEBUG"    1932    "2016-12-01 12:13:44.375"    "The read operation failed. Bytes transferred: 0 Remote IP: 151.184.13.169, Session: 48, Code: 10054, Message: An existing connection was forcibly closed by the remote host"
"DEBUG"    1932    "2016-12-01 12:13:44.375"    "Ending session 48"
"DEBUG"    1932    "2016-12-01 12:13:44.375"    "Creating session 56"
"TCPIP"    1932    "2016-12-01 12:13:44.375"    "TCP - 151.184.13.169 connected to 151.184.13.169:587."
"DEBUG"    1932    "2016-12-01 12:13:44.391"    "TCP connection started for session 55"
"SMTPD"    1932    55    "2016-12-01 12:13:44.391"    "151.184.13.169"    "SENT: 220 BIOSBPM01 ESMTP"
"SMTPD"    1920    55    "2016-12-01 12:13:44.391"    "151.184.13.169"    "RECEIVED: EHLO"
"SMTPD"    1920    55    "2016-12-01 12:13:44.391"    "151.184.13.169"    "SENT: 501 EHLO Invalid domain address."
"DEBUG"    1932    "2016-12-01 12:13:44.391"    "The read operation failed. Bytes transferred: 0 Remote IP: 151.184.13.169, Session: 55, Code: 2, Message: End of file"
"DEBUG"    1932    "2016-12-01 12:13:44.391"    "Ending session 55"

0 Kudos
Reply