VishalS
Novice

K2 Blackpearl for Sharepoint configuration issue with K2 server

Hi All,

 

I'm trying to register and configure K2 server settings in K2 for sharepoint app in SP 2013 but unable to do so.

 

Validation of URL is done successfully in Registration wizard page(refer image 1) but when i click on next ,page loads once and i get a blank page(refer Image 2) and nothing happens after that.Hence not able to make out what exactly is happening.

Earlier i was getting some SSL certificates issue(URL mismatch) due to which even K2 URL validation was getting failed but anyhow i fixed it. 

 

I checked the event logs and getting below mentioned error:

First change exception occurred Exception: System.TimeoutException: The pipe connection was aborted because an asynchronous read from the pipe did not complete within the allotted timeout of 00:02:00. The time allotted to this operation may have been a portion of a longer timeout. ---> System.IO.PipeException: The operation cannot be completed because the pipe was closed. This may have been caused by the application on the other end of the pipe exiting. --- End of inner exception stack trace --- at System.ServiceModel.Channels.PipeConnection.OnAsyncReadComplete(Boolean haveResult, Int32 error, Int32 numBytes) Exception: System.IO.PipeException: The operation cannot be completed because the pipe was closed. This may have been caused by the application on the other end of the pipe exiting. StackTrace: at SourceCode.Security.Windows.Log.OnFirstChanceException(Object sender, FirstChanceExceptionEventArgs e) at System.ServiceModel.Channels.PipeConnection.OnAsyncReadComplete(Boolean haveResult, Int32 error, Int32 numBytes) at System.ServiceModel.Channels.OverlappedContext.CompleteCallback(UInt32 error, UInt32 numBytes, NativeOverlapped* nativeOverlapped) at System.Runtime.Fx.IOCompletionThunk.UnhandledExceptionFrame(UInt32 error, UInt32 bytesRead, NativeOverlapped* nativeOverlapped) at System.Threading._IOCompletionCallback.PerformIOCompletionCallback(UInt32 errorCode, UInt32 numBytes, NativeOverlapped* pOVERLAP)

 

 

The sharepoint is already pointing to one K2 server and this is second server i'm trying to point.

 

Tools Used : K2 BP 4.6.8,K2 Smartforms 1.0.7,K2 Designer for Sharepoint 1.0.1,K2 smartforms Control Pack 1.0.1 

 

Please guide me to fix the issue.


1_1973.png
2_1974.png
0 Kudos
Reply
3 Replies
Amit_P
Novice

Re: K2 Blackpearl for Sharepoint configuration issue with K2 server

Hi Vishal,

Please trun of IE enhance security to "Off" on server and try to do the registration

0 Kudos
Reply
VishalS
Novice

Re: K2 Blackpearl for Sharepoint configuration issue with K2 server

Hi Amit,

 

Thanks for replying.

 

But the IE enhance security was already set to 'OFF' and I'M still facing the same issue 😞 .

Below are the error logs which are been thrown when i try to refresh the SP 2013 service instance:

8060 ProcessPacket Error, Error refreshing Service Instance 'XYZ_sites_k2dev'. Service returned : 'Failed to initialize the Context: URL: https://XYZ Username: Error Details: The remote server returned an error: (401) Unauthorized. Method: SharePointService.initializeContext '.

 

 

Actually the same SP server is been used by our test server too and m building up a new dev server using same SP server.

 

Regards,

Vishal

0 Kudos
Reply
Chadg
Apprentice

Re: K2 Blackpearl for Sharepoint configuration issue with K2 server

VishalS


 


The error you posted:


8060 ProcessPacket Error, Error refreshing Service Instance 'XYZ_sites_k2dev'. Service returned : 'Failed to initialize the Context: URL: https://XYZ Username: Error Details: The remote server returned an error: (401) Unauthorized. Method: SharePointService.initializeContext '.


 


 


Comes up a in several different situation. I can paste  some items that helped other people, it may or may not help. If this not resolved, I suggest you log a ticket with K2 support. 


 


1)  Someone installed K2 on Sharepoint 2013 server before, and K2 for Sharepoint component was kept memorizing the former K2 database connection string in setup manager wizard and not showing for editing. After we detached the K2 databases on Sharepoint server, setup manager shows the database configuration again, and pointting to the latest K2 server databases then problem sloved.


 


2) Run the power shell script for the Sharepoint 2013 App install (S2S Script within the K2 for SharePoint install folder.)
Make sure that the K2 for SharePoint port is open (port 6332). This should allow the host server to directly pink the SharePoint server successfully.
Please have a look at the following help guide in regards to ports.
http://help.k2.com/kb001318
The port can turned on for deployment and then further turned off once it has been completed.


 


 


 

0 Kudos
Reply