HP1
Novice

Date Filter Not working the ListView

Hi,

 

I need some examples of using Date Filetr in List View. It was working in 4.6.5 version of K2 blackpearl and after upgrade to 4.6.9 it stopped working. I'm using a read only List View which has Start Date field and I'm using expression to filter the dates in the DataLabel to display the Date field from the smart object. Would anyone know of a better way to do filter using date in List View. Really appreciate any help and if you can provider some examples. 

 

Thanks,

Vasanth Raphael

0 Kudos
4 Replies
AhmadAbdullah
Apprentice

Re: Date Filter Not working the ListView

Dear ,

i dont think there is a need for an exression to use in list view ,

u may wanna check this link or the following steps .

 

1-U will find these icons on left/top of ur list view (when its in edit mode in k2 designer) just click on the settings icon .

 

3395i543380663C0CEA63.png

 

Note : if u wanna filter by date , then u will need to drag-drop ur date (from expanding smartobject fields)

 

Hope it helps ,

Best regards.

0 Kudos
AhmadAbdullah
Apprentice

Re: Date Filter Not working the ListView

Dear ,

The previous post was an answer to "list view" filteration , but after i checked ur attachments/Images i saw a worklist control

So here is another link if ur scenario was about filtering worklist control in runtime .

go to this link http://help.k2.com/onlinehelp/k2appit/userguide/current/default.htm#Worklist_Control.html#Properties

 

And read the Configure Filters and Sort Options Section .

 

Best regards.

0 Kudos
carlar
Novice

Re: Date Filter Not working the ListView

What is the trick to getting the Filtering Options configure button to enable?  Mine is disabled on my view.

0 Kudos
AhmadAbdullah
Apprentice

Re: Date Filter Not working the ListView

@carla,

 

It would be disabled if you were using Editable List View, please recheck your view, if its anything other than List View, then the filteration option will be disabled.

i mean that you could only use filteration options on "List View"

 

Regards,

Hope it helps.

0 Kudos