Laci
Scholar

Out of Office from Smartform

Jump to solution

Hi All!

 

We created a smartform where the user able to set the out of office. In this action we use the

com_K2_System_Management_SmartObject_OOFUser smartobject

This smartobject's broker is SourceCode.SmartObjects.Services.K2Management.K2ManagementBroker

 

The problem is because the Service Instance Authentication mode is Impersonation and every user who want to use this smartform, needs to have an Admin Server Rights. We try to change the Authentication mode to Serviceaccount , but it is not working (it change back to Impersonation)

 

The out of the box woklist out of office function is not good for us

 

Do you have any suggestions

Thanks

 

0 Kudos
Reply
1 Reply
boringNerd1
Novice

Re: Out of Office from Smartform

Jump to solution

Hi,


 


Are you aware that you can actually set Out of Office from Workspace? Just go to Workspace, click on the username on the bottom left corner of the page, go to Settings and you should see the Out of Office settings.


 


If you play around with the Out of Office settings there while performing a network trace, you will see that the SmartObject the Workspace uses is 'com_K2_System_Workspace_SmartObject_OutOfOfficeUser'. This should be the SmartObject meant for use by the normal users.


 


Avoid using 'com_K2_System_Management_SmartObject_OOFUser' as that is meant for use by Administrators.


 

Reply