DmitryR
Forms Fledgling

K2 OData, connect to the SmartObject doesn't work

Jump to solution

Hello,

Please help. I can't connect to the K2 SmartObject.

I connected to the K2 OData through Excel or Power BI, created sample SmartObject, made it available, but after logon to the K2 I can't see any SmartObjects.

Screenshots below.

 

Available SmartObjects:

DmitryR_0-1626774535599.png

 

OData feed (Excel):

DmitryR_1-1626774688952.png

Info issue:

DmitryR_2-1626775125482.png

 

Labels: (1)
0 Kudos
Reply
9 Replies
DmitryR
Forms Fledgling

Re: K2 OData, connect to the SmartObject doesn't work

Jump to solution

My permission to the SmartObject:

DmitryR_0-1626775541991.png

 

0 Kudos
Reply
NikR
Nintex Employee
Nintex Employee

Re: K2 OData, connect to the SmartObject doesn't work

Jump to solution

Do you see the smartobject if you browse to the following URL via browser?

https://nintexdemo.ru/api/odata/v3

0 Kudos
Reply
DmitryR
Forms Fledgling

Re: K2 OData, connect to the SmartObject doesn't work

Jump to solution
No, I tried it, but in vain. The screenshot "info issue" in my first post.
0 Kudos
Reply
NikR
Nintex Employee
Nintex Employee

Re: K2 OData, connect to the SmartObject doesn't work

Jump to solution

As a test, can you create a simple SmartBox SmartObject then add it to the list of Selected SmartObjects, and see if that works?

0 Kudos
Reply
khanh
Nintex Employee
Nintex Employee

Re: K2 OData, connect to the SmartObject doesn't work

Jump to solution

Hi DmitryR,

 

Can you enable Odata tracing and see if that will give us any more information?

https://community.nintex.com/t5/Internal/How-to-enable-Odata-Tracing-for-SmartObject-Odata-API/ta-p/...

 

0 Kudos
Reply
DmitryR
Forms Fledgling

Re: K2 OData, connect to the SmartObject doesn't work

Jump to solution

Khanh your link doesn't work for me, an issue is: You do not have sufficient privileges for this resource or its parent to perform this action.

 

I turned on OData tracing, please check log file in attachment.

I created the new SmartObject "PowerBI_Test2". 

DmitryR_0-1626936969809.png

 

Physical path to the SmartObject "[Program Files]\K2\WebServices\API\SmartObjectService.OData\v3\PowerBI_Test2\" isn't exist, and folder "v3" isn't exist too.

 

0 Kudos
Reply
boringnerd
Nintex Employee
Nintex Employee

Re: K2 OData, connect to the SmartObject doesn't work

Jump to solution

From your K2 Management, go to Authentication > Claims > Issuers. What issuer are you using? Also check the Realms page to see which realm is using which issuer.

 

Checking this because recently I came across a case where an organization's users are using ADFS to login. If they try to open the OData API with a user that uses the K2 security label, the OData API works.

0 Kudos
Reply
DmitryR
Forms Fledgling

Re: K2 OData, connect to the SmartObject doesn't work

Jump to solution

Hello,

please check screenshots below.

 

Issuers:

DmitryR_0-1627024864959.png

Realms:

DmitryR_1-1627024931811.png

 

0 Kudos
Reply
DmitryR
Forms Fledgling

Re: K2 OData, connect to the SmartObject doesn't work

Jump to solution

The problem is related to Russian as the main system language.

Solution is:

1. Open the "Web.config" file by path: [Program Files]\K2\WebServices\API\SmartObjectService.Odata
2. Find: "<system.web>"
3. After "<system.web>" in new line add: "<globalization culture="en-US" uiCulture="en-US" />"
4. Save file
5. Restart IIS cmd: iisreset

View solution in original post

0 Kudos
Reply