JeffLH
Novice

K2 Five Workflow intermittently not seeing SharePoint List Item Update Trigger

Hello - 

 

I'm seeing a situation whereby K2 Five workflow is intermittently not seeing / begin notified of the SharePoint List Item Update Trigger to start the workflow upon List Item Update.  

 

The issue has been observed from both the EditForm.aspx (SP standard form) Save button as well as a javascript REST API Post action.

 

SharePoint Version History for the List Item does record the List Item Update; however, the Version History display window does NOT show the follow-on Update Workflow execution. 

 

The List Item receives the data update - as recorded in the List Item Version History. Accessing the SharePoint List View ( ... ) > Advanced > K2 Workflows for the Item shows no workflow execution or error for the related timestamp.

 

Has anyone seen this situation of K2 Five Workflow not seeing / being notified of the SharePoint List Item trigger?

 

Suggestions on how best to debug / trace which log files to searc through?  I am working with our operations people(s) to investigate.

 

Thanx!

 

0 Kudos
Reply
1 Reply
ajo
Apprentice

Re: K2 Five Workflow intermittently not seeing SharePoint List Item Update Trigger

Hi there,

First place you could check would be the Event Viewer logs on the K2 server. Under the Applications and Services Logs, you should see K2. This KB may be helpful in further troubleshooting such issues: https://help.k2.com/kb002745


0 Kudos
Reply