Xuber_TGB
Scholar

K2 Five Installation broken after VS 2015 reinstall

Hi,

 

My VS 2015 was behaving oddly so I reinstalled it but first I uninstalled the 2015 K2 aspect on my machine. This led to the K2 setup uninstalling K2 Five entirely. I was fine with this because I knew I could reinstall (and because our new laptop setup means we are no longer tied to an AD, meaning K2 can no longer be run for local Dev debugging - useful!)

 

However, it seems like it's embedded something in the registry and now VS 2015 is complaining on every startup that it can't find the K2 DLL.

 

I tried re-running the K2 Five setup but it defaults to only reinstalling the VS 2015 part and then fails without any error midway through.

 

So I need to know what registry settings to blitz to remove K2 completely so that VS 2015 is okay and I can reinstall K2 Five later if I need the VS aspect.

Labels: (1)
0 Kudos
Reply
4 Replies
khanh
Nintex Employee
Nintex Employee

Re: K2 Five Installation broken after VS 2015 reinstall

Hi Xuber_TGB,

 

Perhaps the following documentation might help, see Manual Environment Clean Up section.

https://help.nintex.com/en-US/k2five/icg/5.3/default.htm#Maintain/Remove.htm?Highlight=remove

 

  1. The K2 menu item is left in the Start menu after the uninstall. Delete this menu item by right-clicking the Start menu and selecting Explore / Open All Users. Then browse to Programs folder and delete the K2 folder.
  2. The SourceCode assemblies remain in the Global Assembly Cache (GAC). Delete all SourceCode assemblies from the C:\Windows\Assembly folder.
  3. The SourceCode registry key remains after uninstall. Delete the registry key located at HKEY_LOCAL_MACHINE > SOFTWARE > SourceCode.
0 Kudos
Reply
tbyrne777
Scout

Re: K2 Five Installation broken after VS 2015 reinstall

I believe that if you want the VS 2015 integration, you need to start with a K2 4.7 install and then upgrade to K2 Five.

0 Kudos
Reply
Xuber_TGB
Scholar

Re: K2 Five Installation broken after VS 2015 reinstall

Hi, I'm unsure if I did this. I am fairly sure this was a new Windows 10 clean installation and I went straight to K2 Five but maybe you are correct.
0 Kudos
Reply
Xuber_TGB
Scholar

Re: K2 Five Installation broken after VS 2015 reinstall

Thanks.

This doesn't work unfortunately. I'm not sure if Windows 10 makes a difference. Obviously the GAC is very different in Windows 10 and is just like a normal file structure unlike Win 7. I can only find empty folders inside it for SourceCode options.

Similarly there is nothing in the Registry matching what's said. What I *do* have in the registry are the entries associated with K2 on VS 2015:
"c:\program files (x86)\microsoft visual studio 14.0\common7\IDE\Extensions\K2\SourceCode.VisualStudio.dll"

These are like this
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\VisualStudio\14.0\CLSID\{07c965e1-7af2-4eff-be2f-9c3980abf35e}
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\VisualStudio\14.0\CLSID\{0ebd98f0-da83-4d49-959f-ea1e5e78ff90}
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\VisualStudio\14.0\Packages\{ab85df7a-ee9a-42cb-877e-e96781a6e60e}
Obviously I'm a bit unsure about just deleting these.
0 Kudos
Reply