JSC
Apprentice

K2 5.3 Update requires Visual Studio 2015

Hello,

 

we want to update from K2 5.0 to K2 5.3 but the installer does not want to continue:

7784iDE53067FEAF7AA4F.png

 

Background info: At first we had installed Visual Studio on that server but due to license restriction (Visual Studio is user based licensing and a server is for more than one user) we had to remove it.

 

I tried to uninstall "K2 for Visual Studio 2015" which was removed pretty fast (too fast?) but the setup still does not install...

 

What could I do to "tell" K2 that this is not installed anymore?

 

regards,

Johann

0 Kudos
Reply
3 Replies
ThinusC
Nintex Employee
Nintex Employee

Re: K2 5.3 Update requires Visual Studio 2015

Hi Johann


 


It sounds like K2 for Visual Studio was not uninstalled successfully.


 


Did you uninstall Visual Studio 2015 before uninstalling K2 for Visual Studio?


 


When you removed K2 for Visual Studio in K2 5.0, did you use the Start Menu > K2 Setup Manager > Modify option to untick the component?


 


Is K2 for Visual Studio still showing up as an installed component in Programs & Features?


 


I’ve not tried this, but when uninstalling K2 for Visual Studio, it needs to unregister the Visual Studio components using a Visual Studio command. If Visual Studio is already uninstalled, this might fail, possible causing K2 for Visual Studio not to uninstall correctly.


 


I know there is Tools available to force uninstall an application, but I would not recommend it.


 


Cheers,


Thinus


 

0 Kudos
Reply
JSC
Apprentice

Re: K2 5.3 Update requires Visual Studio 2015

Hi,

 

I installed VS 2015 a long time ago.

 

I uninstalled "K2 for Visual Studio 2015" using "control panel - program and features"

We do not have "Start Menu > K2 Setup Manager > Modify option" at all...

 

7786i4D3617D104F96B39.png

 

How can I tell the setup that it is not there anymore...?

 

regards,

Johann

0 Kudos
Reply
Gail_K2
Apprentice

Re: K2 5.3 Update requires Visual Studio 2015

Hi, Johann,


I'm a little rusty on my Installer knowledge, but there used to be a "full" vs "custom" option in the installer. Custom installs let you select which components. Based on what you describe, I wonder if you should try using the 5.3 Full Installer (not Upgrade installer) and try a Custom Install instead. That should let you deselect any Visual Studio component, which might work for you.


If that doesn't work, I would recommend you log a support ticket. I know Support has ways to help you remove components that cannot be uninstalled the "normal" way anymore.


I'd love to know how you end up solving this - whether on your own or with assistance. 


 


Best regards,


Gail

0 Kudos
Reply