Eugenio_Z
Novice

Issue with Package Deployment Tool

HI all,

I have a farm with K2 Platform Classic 5.4 FP14...I created an application based on Sharepoint and it’s working fine...The scope of this application is to have a master to clone for other Sharepoint sites….

Now i have to this, but P&D everytime fails with “Missing required Sharepoint related Item”…

I creted and imported the site template from the naster site but the error is still there….

Someone can help me??

 

Best regards

0 Kudos
Reply
13 Replies
YUDI2
Apprentice
Eugenio_Z
Novice

Re: Issue with Package Deployment Tool

Hi Yudi2…

I already check this link...I have the issue only with APP created for SharePoint...I have others apps 100% K2 and i have no issue with P&D…

It’s very strange..i receive the error also if i try to update itself….

I’m going crazy mainly because i have to clone this application for the customer….

0 Kudos
Reply
YUDI2
Apprentice

Re: Issue with Package Deployment Tool

Are you able to locate which sharepoint item is missing? maybe you can try check on HostServer Log file

0 Kudos
Reply
Eugenio_Z
Novice

Re: Issue with Package Deployment Tool

HI, 

When i try to complete the Mapping (manual, automatic fails immediately) i receive the error on all list/library...But the destination site was created using “site template” (source site)…

I supposed some issue with different list ID, but, i repeat, i have the same error trying to update the master application itself…

HostServerlog, no entries about this...sigh

0 Kudos
Reply
YUDI2
Apprentice

Re: Issue with Package Deployment Tool

ok…,   not sure if this can help you to check further.

 

https://help.k2.com/kbs100211

0 Kudos
Reply
Eugenio_Z
Novice

Re: Issue with Package Deployment Tool

I checked no duplicated entries….

But, anyway, i don’t think there is no way to clone “K2 application for Sharepoin”??

That’s crazy...

0 Kudos
Reply
YUDI2
Apprentice

Re: Issue with Package Deployment Tool

I believe you can clone it and should rerun K2 setup and configuration manager to fix the setting on the clone target

 

cheers

0 Kudos
Reply
Eugenio_Z
Novice

Re: Issue with Package Deployment Tool

No no..i mean that i have to clone a K2 application no configuration/server…

I have Sharepoint site A with K2 app...i have to create a separated Sharepoint Site B with the same application (of course different database)

0 Kudos
Reply
YUDI2
Apprentice

Re: Issue with Package Deployment Tool

Ic,, There is no way to do that.

0 Kudos
Reply