Agustinc1913
Novice

Error - Index was out of range

Hi, i am getting this error during creating an app on K2. Five

1d48b9bb-e23d-4d3c-8b64-07718ff51ff3.png

 

0 Kudos
Reply
5 Replies
KevinZ1
Apprentice

Re: Error - Index was out of range

Hi Agustrinc1913,

 

Please have a look at this KB article relating to the same type of issue you are having.
https://community.k2.com/t5/K2-blackpearl-Articles/Index-was-out-of-range-Must-be-non-negative-and-l...


Please let me know if this helps.

Regards
Kevin

0 Kudos
Reply
Agustinc1913
Novice

Re: Error - Index was out of range

Hi Kevin, unable to access. It redirect me to k2 community dashboard

0 Kudos
Reply
Prineel
Scout

Re: Error - Index was out of range

Hi @Agustinc1913,

 

Please try this link:
 

If it does not work, please find the attached pdf which contains the post.

 

Kind Regards

Prineel

Reply
Agustinc1913
Novice

Re: Error - Index was out of range

Nice, an any idea how to configure Workspace SQL Service configuration

0 Kudos
Reply
Prineel
Scout

Re: Error - Index was out of range

Hi @Agustinc1913,

 

The best idea that I have is:

In K2 Management, go to service instances and check if K2 Workspace is there:
 

3f6e847f-fc92-4829-8267-7c7ba4b20e83.png

 

If it is not, then press the add button at the top panel, select the K2 Workspace service type and name it K2 Workspace.
 

2c4a3a1d-c015-443f-8b2f-067fca7c3a98.png

 

The settings hsould autot generate, yu just need to click the generate SMO checkbox:

38e552bc-f153-4ef7-9e43-e409fffdf54d.png

 

If K2 Workspace is already in your service instance, then i recommend opening a support ticket. You can also perhaps click the generate SMO checkbox in hopes that it will reconfigure the smart objects for workspace, but im not sure if it will delete any existing data.

Apologies that you have to deal with this issue :(

 

Kind Regards

Prineel

0 Kudos
Reply