BigB
Canvas Initiate

Does not have Security rights on the Process error when deploying

I am trying to deploy package from P&D tool to UAT 5.2 environment. I am getting error as below:-

Fail Process  WorkflowName
C:\ProgramData\Temp\Deployment\440b3e405a324f209449ba740a75bad1.msbuild(125,5) : error : SmartObject Server Exception: K2:Domain\ABC does not have Security rights on the ‘WorkflowName Process Instances’ SmartObject.. SmartObject: [WorkflowName Process Instances] 

 

The workflow built in 4.7 version and migrated to 5.2 . Recently i did some changes in workflow using K2 studio and deployed on DEV. Now i am trying to deploy package on UAT and it is giving me an error.

I have Server Admin rights and Admin rights on workflow as well.

Labels: (2)
0 Kudos
Reply
5 Replies
KateV
Nintex Employee
Nintex Employee

Re: Does not have Security rights on the Process error when deploying

Hi BigB,

 

Please check if you are a member of the "Package and Deployment" role and "Security Administrators" role, If not yet kindly add your user account in there

 

Once done test again and check if that resolves the issue

 

Should you feel that this post is of use and or an accurate solution to the raised question, I kindly encourage you to mark it as such
using the 'Best Answer', 'Like' and\or ‘Me Too’ options.

 

Cheers,
Kate

 

Nintex will not accept any liability for any issues arising from actions taken in respect of the information provided by any forum member.

 

 

 

 

0 Kudos
Reply
BigB
Canvas Initiate

Re: Does not have Security rights on the Process error when deploying

Hi @KateV 

 

I am already  member of the "Package and Deployment" role and "Security Administrators" role.

 

I am able to deploy other applications.

0 Kudos
Reply
KateV
Nintex Employee
Nintex Employee

Re: Does not have Security rights on the Process error when deploying

Hi BigB,

 

Kindly try to uncheck the option to generate the reporting SmartObjects from your workflow, and redeploy the workflow. Once done check if this helps to resolve the issue

 

Should you feel that this post is of use and or an accurate solution to the raised question, I kindly encourage you to mark it as such
using the 'Best Answer', 'Like' and\or ‘Me Too’ options.

 

Cheers,
Kate

 

Nintex will not accept any liability for any issues arising from actions taken in respect of the information provided by any forum member.

0 Kudos
Reply
khanh
Nintex Employee
Nintex Employee

Re: Does not have Security rights on the Process error when deploying

Hi BigB,

 

I recently ran into this issue and it took a day to track it down. It turned out this would only occur with legacy workflows deployed via thick client tools (i.e K2 Studio or K2 for VS). The key to this is in the error message.

 

K2:Domain\ABC does not have Security rights on the ‘WorkflowName Process Instances’ SmartObject..

 

Can you give the steps below a try and see if that will resolve the issue?

 

1. Navigate to Management site > Categories > Workflow Reports > Workflow Solutions > Your_project > your_WorkflowName Process Instances.

Image 015.png

 

2. Click on Security tab and give the SmartObject Security right (Allow).

Image 016.png

 

Alternatively, you can give Security right (Allow) at the Workflow Solutions category level. Other objects under it will inherit this permission.

 

 

0 Kudos
Reply
tbyrne777
Cloud Wanderer

Re: Does not have Security rights on the Process error when deploying

If you open the Process in Visual Studio, there is an option (in the upper-right corner I believe) where you can uncheck SmartObjects. Unless you know for sure you are using the SmartObjects that get generated with the workflow process, you can uncheck this to allow deployment to proceed.

0 Kudos
Reply