No ratings

SMOSPListItem Error "Input string was not in a correct format"




Symptoms


After copying a SharePoint list from Testing to Production environment using 3rd Party application and deploying a K2 Package with the related SmartForms and Smartobject, the following error is displayed when executing the SMO in Tester Tool: ?Input string was not in a correct format?

Diagnoses


- Created a new SharePoint Content Service Instance for the Production Environment and generated a new SMO for the list. Same issue occurred on execution.
- Migrated the List from Testing to Production environment using SharePoint Template file (.stp) and generated SMO against the new list. SMO executed successfully.
- On the affected List Settings, changed the Column type from Currency to Number. Republished the SMO with the same Name and GUID. SMO executed successfully.
- On the affected List Settings, changed the Column type from Number back to Currency. Republished the SMO with the same Name and GUID. SMO executed successfully.

Resolution

Suspect something changed in the definitions of the SharePoint List after it was migrated using 3rd party software. Changing the affected column to a different type refreshed the column definitions in SharePoint.
Changing it back to the original type and then republished the SMO with the same Name and GUID resolved the issue. Forms that make use of the SMO function correctly.





Labels: (1)
Version history
Last update:
‎08-26-2021 05:14 PM
Updated by:
Contributors