Initialization failed before PreInit Membership

  • 5 October 2016
  • 0 replies
  • 23 views

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Symptoms


After installing K2 in a new environment, there is an error when attempting to access workspace.

An error has occurred.
Please contact your administrator.
Error:
Initialization failed before PreInit: Membership could not be verified: Login failed for user '[Domain][Account]'. Reason: The account is disabled.
Possible causes
- the application pool that workspace is running under may be incorrect.
- the application pool user may not have sufficient rights to access the SQL Server that the K2Workspace database is running on.
- please review log files for more information.

 

Diagnoses


This issue was caused by the user not being present in the SQL database.
 

Resolution

The issue was resolved by adding the mentioned account to the users in the SQL database.




 

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