cancel
Showing results for 
Search instead for 
Did you mean: 

Error launching Forms Designer when list column name is a special character

scalawagd
Nintex Newbie
3 3 1,262

One of our site owners encountered an error when trying to create a Nintex form on a new list.  The error message was as follows:

index error

The key part of the error outlined in red was, "The server encountered an error processing the request.  The exception message is 'Index was outside the bounds of the array.'"

I could recreate the issue on that list with my admin account, but not on other lists on the same site.  I didn't find any community discussions about this, so I started looking at the list structure and settings.  I quickly noticed an unusual column.  One of the columns was named "#".  I changed the name to "Number" and retried launching the forms builder.  Lucky guess!  It worked!  To test it out, I tried some other special characters and ran into the same error.  Interestingly, if the column name had text and a special character, it seemed to work fine, but when it was just a special character, I received the error.  So, for example, using "#" or "$" as the column name resulted in an error.  Using "# of users" or "$ amount saved" did not result in an error. 

The lesson... avoid using just special characters as your column names.

For reference, we're using SharePoint 2013 on premises, and Nintex Forms version 2.7.0.0

Hope this helps!

Brian

3 Comments
Automation Master
Automation Master
scalawagd
Nintex Newbie

Hi Marian,

Thanks for the article reference and keeping me honest!  In this scenario, SharePoint will allow you to name a column with just a special character, such as "#", and the out of the box SharePoint forms for new, edit, and view work correctly without issue.  I confirmed this while troubleshooting the issue, but I forgot to include those details in my initial post, so thanks for the opportunity to clarify that. 

I am not sure if that is true in o365 or other versions of SharePoint, but in our 2013 on-prem farm, it is allowed.  Here is the default new item form with those columns:

special characters as column names in default form

Based on my testing, it seems to only cause trouble if you then try to create a Nintex form when they are named that way.

debosmita03
Nintex Newbie