Nintex Service Bulletin – Action Needed

Document created by mackenzie_lyng on Oct 30, 2018
Version 1Show Document
  • View in full screen mode

In order to ensure continued delivery of premium service, an update may be required to your Nintex for SharePoint On-Premises software by the 5th of December 2018.

 

This update is related to the continuation of Nintex external platform services. The below information will guide you through determining if you are impacted and provide the steps required to remediate the issue.

 

Note: This issue is related only to Nintex for SharePoint On-Premises deployments where the Nintex external platform services has been activated. These services includes Nintex Live (connector actions), Document Generation (DocGenTM), External Start and Live forms (external forms).

 

If you use Nintex for Office 365 or Nintex Workflow Cloud and you do not use Nintex for SharePoint On Premises, no action is needed and you can disregard this message.

 

Background

The Nintex external platform of Nintex for SharePoint On-Premises uses SSL to ensure a secure connection between your on-premises environment and the Nintex external platform cloud infrastructure, enabling your workflows to operate and communicate between these two environments.  During the installation of Nintex external services, several SSL certificates are installed on your on-premises environment to secure these communications.

 

Recently, a group of companies including Google, Mozilla and Apple announced plans to distrust SSL certificates issued by Symantec in their products due to Symantec not complying with industry standard guidelines.  

Ensuring Your Continued Security

At Nintex, the security of our customers’ businesses and data is our top priority. Accordingly, Nintex has decided to join these companies in replacing Symantec-issued certificates in our products and services.

 

We have already begun replacing these certificates in the cloud wherever appropriate. However because we can’t simply ‘push out’ an update to installed on-premises software, we need your help to ensure that these certificates are appropriately replaced so that your Nintex external platform services will continue without interruption.

 

For Nintex SharePoint on-premises customers, it may be necessary to manually update some of the certificates prior to the 5th of December 2018.

 

How can I determine if I need to take action?

You will need to take action to replace the SSL certificates if you meet both of these criteria:

  1. You are using any of the Nintex external platform services which includes Nintex Live (connector actions), Document Generation (DocGenTM) or External Start of Nintex Workflow, or Live forms (external forms) of Nintex Forms for SharePoint On-Premises. Please refer to the following help topics to determine if you are using any of Nintex external platform services: 
  2. Your installed version of Nintex Workflow or Nintex Forms for SharePoint On-Premises is older than the following versions: 
    • Nintex for SharePoint 2016 – Version 4.3.3.0
    • Nintex Workflow for SharePoint 2013 – Version 3.3.1.0
    • Nintex Forms for SharePoint 2013 – Version 2.11.4.0
    • Nintex Workflow for SharePoint 2010 – Version 2.5.7.0
    • Nintex Forms for SharePoint 2010 – Version 1.12.2.30

To determine the version of Nintex Workflow and Forms for SharePoint On-Premises that you have installed, please refer to this post https://community.nintex.com/docs/DOC-1394

If you DO NOT meet both criteria #1 and #2 above, no further action is required.

If you DO meet BOTH criteria #1 and #2 above, please continue…

 

My environment is impacted, what do I need to do?

Nintex has updated the SSL certificates and included additional reliability updates in the latest release of Nintex Workflow for SharePoint On-Premises and Nintex Forms for SharePoint On-Premises. To ensure continuity of Nintex external platform services, simply upgrade to at least the minimum versions outlined below prior to the 5th of December 2018.

 

  • Nintex for SharePoint 2016 – Version 4.3.3.0
  • Nintex Workflow for SharePoint 2013 – Version 3.3.1.0
  • Nintex Forms for SharePoint 2013 – Version 2.11.4.0
  • Nintex Workflow for SharePoint 2010 – Version 2.5.7.0
  • Nintex Forms for SharePoint 2010 – Version 1.12.2.30

 

Note: Upgrading Workflow will automatically apply the SSL certificates updates for Forms as well.

 

What if I am unable or do not wish to upgrade?

If you are unable or do not wish to upgrade your environment prior to the 5th of December 2018, you can instead manually install the updated SSL certificates by using the following provided steps from this post

 

Note: Nintex recommends using these steps only as an interim measure until an upgrade - as detailed above - can be applied to your environment.

 

I still have questions, who can I contact?

If you have any questions or concerns, please reach out to Nintex Support.

 

Know that Nintex always has your security front of mind and will continue to monitor these issues over time to ensure that you will continue to securely enjoy the benefits of the Nintex platform. 

Attachments

    Outcomes