After installing SharePoint 2013 Service Pack 1 (or higher) update, the Workflow service stops working

Document created by nintexsupport Support on Feb 25, 2016
Version 1Show Document
  • View in full screen mode

 

Summary:

After installing SharePoint 2013 Service Pack 1 (or higher) update, the Workflow service stops working

Product:

Workflow for SharePoint 2013

Symptom:

All workflows do not run.

Cause:

Need to apply Microsoft Hot fix to resolve this issue.

Answer/Solution:

Message in the ULS logs:

Application error when access /_layouts/15/Workflow.aspx, Error=Method 'StartWorkflowOnListItem' in type 'Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider' from assembly 'Microsoft.SharePoint.WorkflowServices, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' does not have an implementation. 

 

System.TypeLoadException: Method 'StartWorkflowOnListItem' in type 'Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider' from assembly 'Microsoft.SharePoint.WorkflowServices, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' does not have an implementation.  

 

Getting Error Message for Exception System.Web.HttpUnhandledException (0x80004005): Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> System.TypeLoadException: Method 'StartWorkflowOnListItem' in type 'Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider' from assembly 'Microsoft.SharePoint.WorkflowServices, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' does not have an implementation.   

 

This is a well known issue and there is a hotfix that came out to address it.  However we cannot advise on what to do to fix this issue, as it is not Nintex specific.

 

Here are tests that we need to do to validate these findings:

 

1.  Create a SharePoint Designer Workflow and run it on an item.

2.  If any of the above errors are received then the Microsoft hot fix should be applied.

 

There are many resources online, MSDN, TechNet, etc, that address this specific issue with the same ULS message.

Link to hot fix: http://www.microsoft.com/en-us/download/details.aspx?id=42898

Additional resources that could help in resolving the issue (information use only):

 

http://social.technet.microsoft.com/wiki/contents/articles/29100.after-installing-sharepoint-2013-service-pack-1-or-higher-update-workflow-service-stops-working.aspx

 

https://social.technet.microsoft.com/Forums/windowsserver/en-US/bc32f931-d304-40ae-b84a-7c70208b1689/sharepoint-2013-clicking-on-list-item-workflows-link-returns-error?forum=sharepointadmin

Attachments

    Outcomes