Failed to send notification. Cannot retrieve the Information for application credential key.

Document created by nintexsupport Support on Dec 23, 2015
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Summary:

Nintex not sending emails, giving error in the workflow comment section: “Failed to send notification. Cannot retrieve the Information for application credential key.” At the same time, we started getting issues with the people picker. It would not resolve anything.

Product:

All Workflow Products

Symptom:

Workflows will fail with the below error. Email notifications will not be sent.  Failed to send notification. Cannot retrieve the Information for application credential key.

Cause:

Is caused by a change made to the farm, for example, adding a new web front end server. People picker account settings can become corrupted.

Answer/Solution:

Firstly try to re-enter the username and password for the people picker using PowerShell command:

PS C:\> STSADM.exe -o setproperty -pn peoplepicker-searchadforests -pv "forest:*YOURDOMAIN*,*USERPICKACCOUNT*,*USERPIKPASSWORD*" -url http://*YOURWEBAPPLICATION*

If you get the same error, then this will confirm the people picker is the issue, now run the below command to resolve the issue.

PS C:\> stsadm -o setapppassword -password *USERPICKPASSWORD*
Operation completed successfully.

PS C:\> STSADM.exe -o setproperty -pn peoplepicker-searchadforests -pv "forest:*YOURDOMAIN*,*USERPICKACCOUNT*,*USERPIKPASSWORD*" -url http://*YOURWEBAPPLICATION*
Operation completed successfully.

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