Skip navigation
All Places > Getting Started > Blog > Authors djfox

Getting Started

1 Post authored by: djfox

This describes a bug found in this 2010 Nintex Workflow action:  Create item in another site.

(No worries: This has been reported to support)

 

When configuring the action, these errors occur when creating an item in a list with an Ampersand (&) in the Title (not in the url.)

 

When the title contains a Space ( ) and an Ampersand (&) in the title, these errors appear:

Warning: Error validating configuration. An error occurred while parsing EntityName. Line 1, position 40

Message from webpage: XML is not valid; CAML builder could not be populated.

 

 

When the title contains an Ampersand (&) with no preceding Space (  ) these errors appear:

Warning: Error validating configuration.  ‘  “ ‘ is an unexpected token.  The expected token is ‘;’. Line 1, position 47.

Message from webpage: XML is not valid; CAML builder could not be populated.

 

Note: Lists with these characters did NOT produce an error:

underscore ( _ )

exclamation ( ! )

Semi-colon ( ; )

At ( @ )

Pound ( # )

Dollar ( $ )

Percent ( % )

Asterisk ( * )

Left parenthesis (
(  )

Right parenthesis (
)  )

 

Work Around:  If you are stuck with the Title and process dictates that you cannot remove the offending character, just create a new list in the target site that is an exact duplicate of your target list.  Make sure the Title of the new list does not contain any offending characters.  Use the new list as a holding area. Write a workflow on this list to copy the items from this temporary list to the target list using the Copy Item or Create Item action to copy the item to the target list.  After the item is copied, delete the item from the temporary list.

Filter Blog

By date: By tag: