andrew.beals@nintex.com

Error connecting to the workflow manager

Blog Post created by andrew.beals@nintex.com Support on Sep 2, 2015

Upon opening the Nintex Workflow designer for O365 you receive the following error in the ribbon:

This issue generally indicates that the Nintex Workflow app cannot communicate with the SharePoint tenant. The sharepoint app will make a request to your site from the following URL:

https://yourtenantname-siteapplicationuniqueidentifier.sharepoint.com/

This call is being made from the SharePoint app itself. If this call fails you either do not have appropriate permissions or you do not have the required domains added to trusted sites.

 

By default you do not need to add any domains to your trusted sites however when a group policy is being applied to increase browser security you may need to add sites to your trusted sites to allow otherwise "unsafe calls" to pass successfully. Browser settings that are modified by a local group policy are pushed down to your machine by your domain's activate directory. To verify that the browser is not being restricted by domain policy try logging in to your tenant from another device outside your organization.

 

If you do find that your machine is restricting these requests please add the following domains to your trusted sites.

To do this, follow these steps: In Internet Explorer, click Tools, click Internet Options, and then click the Security tab. In the Select a Web content zone to specify its current security settings box, click Trusted Sites, and then click Sites. Add the following sites to this dialogue:

workflowo365.nintex.com

*.sharepoint.com

 

Lastly, this issue could also be occurring due to workflow manager not being installed to your team site. This feature can be added by reviewing the following blog post:

Error connecting to the workflow manager: Operation is not valid due to the current state of the object

 

Please contact support if you have any additional issues.

 

Cheers,

Andrew Beals

Outcomes