Workspace loads but doesn't complete

  • 16 February 2021
  • 0 replies
  • 17 views

Userlevel 4
Badge +16




 








Workspace loads but doesn't complete































This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.




Issue



After an upgrade from K2 4.7 to K2 Five, Workspace no longer loads. On Workspace the loading screen is displayed but doesn't complete:



Image



 



 



Symptoms



This issue seems to extend to more areas than only Workspace and appears to be caused by outdated or incorrect versions of a SourceCode.Forms.Controls.Web.ControlPack.Common.dll assembly.



When searching for this file on the file system it was found in 3 places:



 



 





{K2 Install location}K2 blackpearlBinControlPack Controls



{K2 Install location}K2 blackpearlK2 Smartforms Designerin



{K2 Install location}K2 blackpearlK2 Smartforms Runtimein





 



 



When this file is present, it seems that K2 loads the assembly on the file system, instead of loading the file from the K2 database. This then causes the Workspace to not load, but when running network traces you can see that Workspace loads and completes.



 



Also, on the K2 Management page when trying to access data fields of a workflow, they are not loaded.



Image




This indicates that more sections might also be affected with the same type of behaviour.



 



 



 



Resolution



- Firstly, make a backup of the file (SourceCode.Forms.Controls.Web.ControlPack.Common.dll) found on the file system.



- After the Backup has been made, delete the files.



- Next, restart IIS and the K2 Service.



The Workspace page, and the Data fields of a workflow on the K2 Management page should now load as expected.










0 replies

Be the first to reply!

Reply