Unable to deploy new Workflow in K2 Five with "Missing reference at emailconfiguration in Event 'Send Mail" error appearing

  • 16 February 2021
  • 0 replies
  • 10 views

Userlevel 4
Badge +17
 

Unable to deploy new Workflow in K2 Five with "Missing reference at emailconfiguration in Event 'Send Mail" error appearing

kbt149268

PRODUCT
K2 Five
BASED ON
K2 Five (all)
This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.

Issue

Unable to deploy any Workflow in K2 Five with the following error appearing:

 

"Missing reference at emailconfiguration in Event 'Send Mail. Error Object reference not set to an instance of an object ...Stack Location Process 'Send Mail' >Email Event ''Send Mail > end Stack"

 

Image

Symptoms

This occurs due to the user permission levels that are set on the environmental field that is blocking the deployment on the development Environment Field, that is set as Default.

Resolution

To resolve this, remove the permission to allow the workflow to deploy successfully.

 

Image

 

Note if there are users specified on Security level, only the users specified will be able to deploy the workflow with read-only or modify rights. If there is no security specified everyone will be able to deploy workflows.

0 replies

Be the first to reply!

Reply