Activating OData on K2 Management not working as expected

  • 16 February 2021
  • 0 replies
  • 6 views

Userlevel 4
Badge +16




 








Activating OData on K2 Management not working as expected



























This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.




Issue



Please note that this article is applicable to K2 5.0 . For the configuration required in K2 5.1 - 5.3, please see the following article: http://help.k2.com/support-services/kbt167342


When the activating OData on K2 Management.



Image



 



The tick box shows that it's active, but this error appears when navigating to the URL:






{"Message":"The OData Service for SmartObjects in K2 has been disabled, please use K2 Management to enable it."}





 



Image



 



 



Symptoms



The OData activation does not work as expected for Power Bi OData feeds.



Resolution



The service account needs to be added to the API management security. (The service account always needs static rights to the API security.)



 



Image



If the K2 Service account is separate from the K2 Application Pool Account (i.e. DENALLIXK2Service and DENALLIXK2WebService); the K2 Application Pool account will also need to be a part of the 'API Administrators'.




 










0 replies

Be the first to reply!

Reply