'Unresolved Message' at the bottom of the screen prevents workflow deployment

  • 15 February 2022
  • 0 replies
  • 0 views

Userlevel 4
Badge +16




 








'Unresolved Message' at the bottom of the screen prevents workflow deployment



























This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.




Issue



A [Unresolved Message] error appears when deploying the workflow. There are no other Red Exclamation points appearing in the workflow when clicking through the different steps.



Image



Symptoms



In this particular scenario, the [Unresolved Message] error was pointing to an orphaned process data field with a special character. This process data field was previously created but didn't delete correctly. It's now out of sync with the rest of the workflow and prevents further deployment of the workflow. The error shows up when viewing the workflow definition in .json



Image



To get the workflow .json file, you can complete the following steps:


- Open the workflow in Chrome
- Press F12 and click on console
- Clear the console by clicking the no-entry sign



Image



 



- Select all the JSON and copy it
- Use http://jsonviewer.stack.hu/



- Open the URL and paste the copied JSON
- Click Format to make sure the JSON is valid
- Then Click the Viewer tab.



Image



 



 



Troubleshooting Steps



To resolve this issue:



1. Add a generic process data field with a special character in its name. Call it 'STSS<'.



2. Click the Save icon to save the workflow and close out of it.



3. Edit the workflow and delete the process data field in (step 1).



The error will go away and you should now be able to deploy the workflow.










0 replies

Be the first to reply!

Reply