Unable to deploy SharePoint Service Object between sites in K2 Five, incompatibility found

  • 15 February 2022
  • 0 replies
  • 1 view

Userlevel 4
Badge +16




 








Unable to deploy SharePoint Service Object between sites in K2 Five, incompatibility found





























This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.






LEGACY/ARCHIVED CONTENT


This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.




Issue



Cannot deploy SharePoint Service Object between Site Collections and the following message appears:



 



"K2 5.0 Package & Deployment - Incompatibility Found"



 



Image



Symptoms



It was noted that the associated SmartObject was out of sync thus no packages could be deployed.

Troubleshooting Steps



To resolve this issue, please do the following: 



1. Go to the K2 Application on the document or custom library and validate if the SmartObject needs to be regenerated.



Image



 



2. If SmartObject regeneration is needed, this will need to be done as above.



3. Create a new package and deploy it to the environment. The incompatibility issue on the document or custom library will no longer be present.










0 replies

Be the first to reply!

Reply