Local storage feature of the browser is not accessible

  • 15 February 2022
  • 0 replies

Userlevel 4
Badge +16


Local storage feature of the browser is not accessible

This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.


Attempting to launch the K2 Workflow Designer results in the following behavior:


Uh oh...
Designer can not be loaded because the Local Storage feature of the browser is not accessible.
This could be due to the browser being in private / incognito mode
Local Storage is required to ensure you don't lose your work due to network interruptions


Before You Begin

1.  The most likely cause is that the browser is running in private/incognito mode. The K2 Workflow Designer uses the local storage/indexedDB APIs to ensure you don't lose your work due to network interruptions.


Local storage/indexedDB is not accessible when the browser is running in private/incognito mode.



2.  If not running in private/incognito mode, another cause is that [Internet Options > General > Browsing history > Settings > Caches and databases > Allow website caches and databases] is disabled locally or via group policy.





How-to Steps

To work with the K2 Workflow Designer:
1.  Run the browser in normal mode if using Internet Explorer.

2.  Enable the 'Allow website caches and databases' if possible.  If this option is grayed out, it is likely that a network group policy is in place. This would be policies underneath: [User Configuration > Administrative Templates > Windows Components > Internet Explorer > Internet Control Panel > General Page > Browsing History].
- Allow websites to store application caches on client computers.
- Allow websites to store indexed databases on client computers.


3. Another option would be using Chrome, as it will not be affected by Internet Explorer group policy.

0 replies

Be the first to reply!