Solved

Is the SharePoint connector supporting multiple content types on a list?

  • 30 September 2020
  • 6 replies
  • 0 views

Userlevel 3
Badge +9

A list on SharePoint 365 has multiple content types. Nintex Online supports nicely the creation of multiple forms. But in Nintex Workflow Cloud a Create List Item action keeps the Add Fields button greyed out on this list? Are the multiple content types the reason for this?



icon

Best answer by WouterT 2 October 2020, 18:51

View original

6 replies

Userlevel 5
Badge +6

@WouterT Multiple content types should work, just tested and confirmed. Have you tried just reopening the workflow or refreshing the lists.

Userlevel 3
Badge +9

Thank you @leighburke for taking the time to test it even. Well, after a day of searching and testing I think I found a possible minor bug. I usually create a list with a name without spaces to keep a tidy URL e.g. ContentPackages. Then I change the name by adding a space to have nicer pages: Content Packages. When you do this the error as I described occurs. After changing the name back it works again. I noticed that it happened with all lists that had double word names. If this is a minor bug I hope it can be corrected.

Badge +12

Well done @WouterT 



as a life long lover of URLs with no %20's I do this all the time when creating lists and libraries.



 



Great pickup also hope the bug is addressed soon.




Cheers

Userlevel 3
Badge +9
Not just for spaces but for any change in the name I notice. Keep URL and list name identical if you want the Data sources to work.
Userlevel 5
Badge +6

@WouterT  Are you able to replicate the issue consistently, I would be raising this with our support team. I just tried and was unable to replicate issue but I may of missed something.

Userlevel 3
Badge +9

The name of this topic no longer applies. It all seems to come down to a glitch in the Data Sources page. I was able to replicate the error on a test list today easily.



First created a list in SharePoint online:





Then tried to create a data source in NWC:





All fine so far.



Now renamed the list:





And refreshed the Data Source page and then tried without success:





How can it be that this happens to me but not to you? After some more investigation this morning I think the difference might be in one slash '/'. I put a slash at the end of my SharePoint site URL as I learned from some Nintex demo videos. But when I don't things behave different suddenly.





With the slash the new given name appears in the pull down list and no columns available.





Without the slash it shows me the 'original URL name' and the columns are available again.



Sorry to bother you with such a detail but it did cost my a lot of time and I am sure it will save others time when corrected.



 

Reply